CISCO静态路由故障排除实验

CISCO网络故障排除几道小题的解析

CISCO网络故障排除1(静态路由的故障排除)

前言

最近在学习一些网络里面的一些故障的排除,这里面我们借鉴了几个CISCO的小题来简单的解析说明一下。

https://pan.baidu.com/s/1Cb2\_jhmPqZ2GPR\_arMGINA

提取码:t5tw

三个小题可以自行到百度网盘里面提取。之后用CISCO模拟器直接打开就可以了。

第一题:静态路由故障排除

题目要求:

1545390430544

场景

在本实验中,首先您将在每台路由器上加载配置脚本。这些脚本含有错误,会阻止网络中的端到端通信。您需要排除每台路由器的故障,找出配置错误并随后使用适当的命令纠正配置。当您纠正了所有的配置错误之后,网络中的所有主机就应该能够彼此通信了。
任务 1:布线、清除配置并重新启动路由器

步骤 1 构建一个类似拓扑图所示的网络。

所有路由器上的 LAN 接口都是 Fa0/0
从 Branch 到 HQ 的连接是 S0/0/0 到 S0/0/0
从 HQ 到 ISP 的连接是 S0/0/1 到 S0/0/1

步骤 2 使用 erase startup-config 命令清除每台路由器上的配置,然后使用 reload 命令重新启动路由器。如果询问您是否保存更改,回答 ‘no’。(使能口令为 class。)

步骤 3 使用表中的地址配置主机。

任务 2:使用提供的脚本加载路由器

步骤 1 将以下脚本加载到 Branch 路由器。将脚本粘贴到路由器中之前,请确保您处于全局配置模式中。


hostname Branch
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.20.1.129 255.255.255.128
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 172.20.1.1 255.255.255.128
clock rate 64000
no shutdown
!
ip route 0.0.0.0 0.0.0.0 172.20.0.129
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end
步骤 2 将以下脚本加载到 HQ 路由器



hostname HQ
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 172.20.0.129 255.255.255.128
duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 172.20.1.2 255.255.255.128
no shutdown
!
interface Serial0/0/1
ip address 192.168.38.254 255.255.255.252
no shutdown
!
ip route 192.168.39.64 255.255.255.192 192.168.38.253
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end
步骤 3 将以下脚本加载到 ISP 路由器



hostname ISP
!
!
no ip domain-lookup
!
interface FastEthernet0/0
ip address 192.168.39.65 255.255.255.192
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.38.253 255.255.255.252
no shutdown
!
ip route 172.20.0.0 255.255.255.0 192.168.38.254
!
!
!
!
line con 0
line vty 0 4
password cisco
login
!
end
任务 3:Branch 路由器故障排除

步骤 1    从连接到 Branch 路由器的主机开始排除故障。

在主机 PC1 上,是否能 ping 通 PC2? _____________ 

在主机 PC1 上,是否能 ping 通 ISP LAN 上的 Web 服务器? _____________ 

在主机 PC1 上,是否能 ping 通其默认网关? _____________
步骤 2    接下来检查 Branch 路由器是否存在配置错误。首先查看该路由器上每个接口的状态信息摘要。

这些接口的状态是否有任何问题? 


____


____


____



如果这些接口的状态有任何问题,请记下用来修正配置错误的命令。



____


____


____
步骤 3 如果在上面记录了任何命令,请现在将这些命令应用于路由器配置。

步骤 4    如果上一步对配置进行了更改,请再次查看路由器接口的状态信息摘要。

接口状态摘要信息是否显示有任何配置错误? _____________ 
如果回答是“有”,请再次对接口的状态进行故障排除。
步骤 5    对 Branch 路由器上的静态路由配置进行故障排除。首先查看路由表。

路由表中显示有哪些网络? 


____


____


____

路由表是否有任何问题? 


____


____


____

如果路由表有任何问题,请记下用来修正配置错误的命令。 


____


____


____
步骤 6 如果在上面记录了任何命令,请现在将这些命令应用于路由器配置。

步骤 7    如果上一步对配置进行了更改,请再次查看路由表。

路由表信息是否显示有任何配置错误? _____________ 
如果回答是“有”,请再次对路由表进行故障排除。
步骤 8    再次 ping 各个主机。

在主机 PC1 上,是否能 ping 通 PC2? _____________ 

在主机 PC1 上,是否能 ping 通 ISP LAN 上的 Web 服务器? _____________ 

在主机 PC1 上,是否能 ping 通 HQ 的 Serial 0/0/0 接口? _____________
任务 4:HQ 路由器故障排除

步骤 1    从连接到 HQ 路由器的主机开始排除故障。

在主机 PC2 上,是否能 ping 通 PC1? _____________ 

在主机 PC2 上,是否能 ping 通 ISP LAN 上的 Web 服务器? _____________ 

在主机 PC2 上,是否能 ping 通其默认网关? _____________
步骤 2    接下来检查 HQ 路由器是否存在配置错误。首先查看该路由器上每个接口的状态信息摘要。


这些接口的状态是否有任何问题?


____


____


____

如果这些接口的状态有任何问题,请记下用来修正配置错误的命令。 


____


____


____
步骤 3 如果在上面记录了任何命令,请现在将这些命令应用于路由器配置。

步骤 4    如果上一步对配置进行了更改,请再次查看路由器接口的状态信息摘要。

接口状态摘要信息是否显示有任何配置错误? _____________ 
如果回答是“有”,请再次对接口的状态进行故障排除。
步骤 5    对 HQ 路由器上的静态路由配置进行故障排除。首先查看路由表。

路由表中显示有哪些网络? 


____


____


____

路由表是否有任何问题? 


____


____


____

如果路由表有任何问题,请记下用来修正配置错误的命令。 


____


____


____
步骤 6 如果在上面记录了任何命令,请现在将这些命令应用于路由器配置。

步骤 7     如果上一步对配置进行了更改,请再次查看路由表。

路由表信息是否显示有任何配置错误? _____________ 
如果回答是“有”,请再次对路由表进行故障排除。
步骤 8    再次 ping 各个主机。

在主机 PC2 上,是否能 ping 通 PC1? _____________ 

在主机 PC2 上,是否能 ping 通 ISP 路由器的 Serial 0/0/1 接口? _____________ 

在主机 PC1 上,是否能 ping 通 ISP LAN 上的 Web 服务器? _____________
任务 5:ISP 路由器故障排除

步骤 1    从连接到 ISP 路由器的主机开始排除故障。

在模拟模式中,是否能从 ISP LAN 上的 Web 服务器 ping 通 PC1? _____________ 

在模拟模式中,是否能从 ISP LAN 上的 Web 服务器 ping 通 PC2? _____________ 

在模拟模式中,是否能从 ISP LAN 上的 Web 服务器 ping 通默认网关? _____________
步骤 2    接下来检查 ISP 路由器是否存在配置错误。首先查看该路由器上每个接口的状态信息摘要。

这些接口的状态是否有任何问题? 


____


____


____

如果这些接口的状态有任何问题,请记下用来修正配置错误的命令。 


____


____


____
步骤 3 如果在上面记录了任何命令,请现在将这些命令应用于路由器配置。

步骤 4    如果上一步对配置进行了更改,请再次查看路由器接口的状态信息摘要。

接口状态摘要信息是否显示有任何配置错误? _____________ 
如果回答是“有”,请再次对接口的状态进行故障排除。
步骤 5    对 ISP 路由器上的静态路由配置进行故障排除。首先查看路由表。

路由表中显示有哪些网络? 


____


____


____

路由表是否有任何问题? 


____


____


____

如果路由表有任何问题,请记下用来修正配置错误的命令。 


____


____


____
步骤 6 如果在上面记录了任何命令,请现在将这些命令应用于路由器配置。

步骤 7    如果上一步对配置进行了更改,请再次查看路由表。

路由表信息是否显示有任何配置错误? _____________ 
如果回答是“有”,请再次对路由表进行故障排除。
步骤 8    再次 ping 各个主机。

在模拟模式中,是否能从 ISP LAN 上的 Web 服务器 ping 通 PC1? _____________ 

在模拟模式中,是否能从 ISP LAN 上的 Web 服务器 ping 通 PC2? _____________ 

在模拟模式中,是否能从 ISP LAN 上的 Web 服务器 ping 通 Branch 路由器的 WAN 接口? _____________
任务 6:思考题

本次实验中提供的脚本存在多处配置错误。请在下列位置简要写出您找到的错误。 


____


____


____



____


____


____



____


____


____


在本任务结束时,您的完成率应该是 100%。如果完成率不是 100%,单击 Check Results(检查结果)按钮进行检查,必要时进行故障排除。

以上全部都是题目的要求,这里面其实我们只要关注这里面的完成度到100就行了。

首先一步一步的来

1545390645701

首先是连线

1545390748878

如图我们连接好了线路,这个时候我们还没有配置IP地址,但是这时候完成度已经10%了。

接着下一步,

1545390798741

这里面我们把第二步还有第三步一块加起来进行说,IP地址怎么配置这个不用说了吧!

第二步是说清楚配置然后用reload重启路由器。这里面我们要注意告诉我们路由器的密码是class

我们先进去hq这个路由器配置这个其他的都一样,自行实践。

HQ>enable 
Password: 
HQ#era
HQ#erase s
HQ#erase startup-config 
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]y[OK]
Erase of nvram: complete
%SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
HQ#reload
Proceed with reload? [confirm]n

这里面是清除的过程。

全部清除完毕之后我们进行IP地址的配置。

记得要在配置完IP地址之后开启端口 NO SHUTDOWN

然后我们配置完IP地址之后这时候进度已经飙升到78%了。

1545391294573

继续进行,就是加载它的脚本了。

1545391321422

Branch(config-if)#exit
Branch(config)#hostname Branch
Branch(config)#!
Branch(config)#!
Branch(config)#no ip domain-lookup
Branch(config)#!
Branch(config)#interface FastEthernet0/0
Branch(config-if)# ip address 172.20.1.129 255.255.255.128
Branch(config-if)# duplex auto
Branch(config-if)# speed auto
Branch(config-if)# no shutdown
Branch(config-if)#!
Branch(config-if)#interface Serial0/0/0
Branch(config-if)# ip address 172.20.1.1 255.255.255.128
Branch(config-if)# clock rate 64000
Branch(config-if)# no shutdown
Branch(config-if)#!
Branch(config-if)#ip route 0.0.0.0 0.0.0.0 172.20.0.129
Branch(config)#!
Branch(config)#!
Branch(config)#!
Branch(config)#!
Branch(config)#line con 0
Branch(config-line)#line vty 0 4
Branch(config-line)#password cisco
Branch(config-line)# login
Branch(config-line)#!
Branch(config-line)#end
Branch#
%SYS-5-CONFIG_I: Configured from console by console

Branch#

这个玩意复制粘贴就行了,记住是全局模式。

HQ#这个是特权模式

HQ#(config)这个是全局

HQ#(config-if)这个是端口配置

其他的两个都一样。

这三个脚本都加载完了我们的进度就已经到了91%了哎,多开心!

继续进行任务三了,就是排除故障,那么我们用ICMP的包看看排除吧!

我们知道PING命令就是发出的ICMP包,我们PING试一试,看看题目的要求OK不OK

1545391570118

他叫我们Ping pc2 啊 服务器啊这个我们动动脑子都能想明白肯定Ping不通因为有问题吗,但是为了以防万一还是要Ping一下,我们看超时。这里他叫我们Ping网关,这个现在而言猜测应该是Ping的通的,因为这个题是说路由的问题吗,应该问题不会出在我们内网这一段。

我们ping网关

1545391697746

我们看没问题啊,这就说明我们到路由器这一段根本没问题!

然后继续向下进行啊,那么我们就要说是哪里出现的问题了。

开启监控模式,我们在PC1发一个包到PC试一试!

1545392093068

1545392180703

1545392266054

我们看啊,取得时候完全没问题,他已经到了PC2了,但是回来的时候挂在路由这里了哎,那我们猜测他找不到回来的路由。我们进入HQ查看路由表。

果然没有到PC1的路由。那么我们就要给他添加一条路由了。

HQ(config)#ip route 172.20.1.128 255.255.255.128 172.20.1.1

1545392467629

我们发现OK问题排查完成!

继续进行,看看发往web服务器的包问题出在哪里?

1545392631437

1545392647133

我们发现这个也是过得去回不来,我们查看路由表。

1545392699415

1545392804031

这个路由表指有到172.20.0.0网段的路由,这里我们猜测PC2跟他通讯应该是OK的。

猜想正确,这里面我们简单粗暴一点,因为这个ISP路由器在外面就只有一个接口,我们直接叫他的所有包都给这个S0/0/1接口

ISP(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1

ISP(config)#

ISP(config)#no ip route 172.20.0.0 255.255.255.0 192.168.38.254

ISP(config)#no ip route 192.168.2.0 255.255.255.0 Serial0/0/0

删除并且设定路由,这里面我们试一试看看PC1通了吗。

1545392950798

OK问题解决了!

这还是PC1,PC2,WEB服务器都能够PING通,但是这时候我们为什么进度还是94%!!!!我们查看检查说是我们Brunch还有ISP这两个路由器的静态路由配置有问题啊,这个我们是在有点····,经过我们考虑是路由设定的不严格导致的问题,我们设定严格的路由试一试!

Branch(config)#ip route 0.0.0.0 0.0.0.0 172.20.1.2

删除原先的路由,这里重新设置一下。我们发现变道97%了

然后我们设置ISP的路由

ISP(config)#ip route 172.20.0.0 255.255.254.0 192.168.38.254

删除原先的路由然后我们发现100%进度。完成!